Amazon Experiencing Problems
Incident Report for CompetitionSuite
Resolved
Amazon Web Services has resolved their issue and will continue monitoring.
Posted over 1 year ago. Sep 14, 2017 - 16:39 EDT
Investigating
Amazon Web Services is experiencing increased error rates related to their S3 offering. CompetitionSuite utilizes S3 for hosting of recaps, schedules, and other static files.

You can view the AWS status here: http://status.aws.amazon.com/
Posted over 1 year ago. Sep 14, 2017 - 15:14 EDT